When your games go on the fritz - Suteneko's repair & mod thread.

Team work makes the dream work!

1 Like

SEGA System 16b 171-5797 ROM Board Repair:

This is a follow up to a previous “repair” where I found this E-Swat 171-5797 ROM board to be faulty:

Any time this ROM board was inserted into a working SEGA System 16b Motherboard you would get a black blank screen and no sound.

While looking around the board originally I had discovered that the axial salmon coloured non-polarized capacitor at C109 had a small crack across it and when pressed very lightly broke away:

I couldn’t find anywhere to buy replacements for this sort of capacitor and put it to one side to look at properly some other time.

Recently I was salvaging parts from some old spare junk VCR PCB’s and lo and behold noticed they were using the same type of capacitors which jogged my memory about this ROM board and de-soldered a bunch of them, of which a fair few were the exact same banding as the one I needed to replace:

I didn’t expect this to be the end of the problems and sadly that was the case the board was still dead.

I decided to test the 4 470µF and 1 x 4.7µF capacitors and while their capacitance measured fine their ESR while not bad enough to stop them working was a little high so I replaced them all anyway:

Again as expected this didn’t change anything and the board was still not working.

So I got at my logic probe set to TTL level and started probing around the board while it was turned on to see if I could discover what was going on.

I had correct activity on all the SOUND and Graphics ROM, however I was getting zero activity on any of the input and output pins on the Program ROM :

These Program ROM are 27C2001 EPROM and to test farther I needed to check if they were getting power and connected correctly to ground:


VCC is the 5v power input pin which is on pin 32
VSS is the Ground pin which is on pin 16.

For those curious VPP is for the re-programming voltage input and can be ignored here.

Using my multi-meter I was able to confirm 5v was present and the ground was also connected properly.

These Program ROM are connected to two custom QFP SEGA IC (a SEGA 315-5250 and a SEGA 315-5248 on the solder side of the board) and a HD74HC139P 74xxxx Series TTL Logic IC.

The solder on the custom SEGA IC didn’t look the greatest but had no visible continuity issues.
Regardless I re-flowed their solder just to be on the safe side:

No change, so I de-soldered the HD74HC139P and went to test it in my Universal Programmer:


It tested good so got soldered back onto the PCB.

So now I either have a bad custom SEGA IC which can not be replaced or a broken trace somewhere.

I start to have a much closer look all over the PCB under magnification and eventually notice this:

Unfortunately the 3 traces go underneath the IC2 located Program ROM so I had to remove the EPROM and the socket to be able to test these 3 traces properly:

Using the continuity mode of my multi-meter I discover that the top 2 traces are still fine however the trace that connects to PIN 2 of the Program ROM (Address line 16) is broken.

Usually here I would scrape away the solder mask a little around the break and re-connect the trace with some thin gauge wire, however at present I don’t have a fibreglass pen at hand so I had to resort to a bodge wire which i placed on the underside of the ROM board:

And working again:


Since this is a repaired ROM board and because I already have a working E-Swat ROM Board I am tempted to convert this into another game (possibly Golden Axe) in the future.


Awesome write up! I always love seeing how you go about your repairs. I need to pick your brain about my Raiden Fighters Jet board that doesn’t have any sound. The amp works… But no sound.


I think there’s a limit on image uploads. Try again later.

1 Like

Thanks for the support as always dude!
Send me a DM regarding Raiden Fighters with a few photographs and we can figure something out!

1 Like

Nintendo DS Lite Cartridge Slot repairs:

I’ve done a lot of DS Lite repairs and generally they have never really been worth the time or effort to work on considering how cheap they can still currently be obtained for, the many issues they can end up having and the comparatively high cost of replacement parts.

However, recently I got handed over two very nice condition DS lites:

Everything is working great apart from both of them have non working “SLOT 1” DS cartridge slots.

The deal here being if I can repair them I get to keep the black DS lite for myself.

Which I decided to take up as the only DS lite I had is actually the result of combining many trash free systems together to make one working system and even then I still had to use parts of a 3rd party shell casing to bring it all together.

So anyway, I bought 2 replacement DS cartridge slots from Zedlabs:

Turning over the Pink DS lite and removing the Dummy GBA Cartridge:

The Battery and two feet are removed:

Four Tri-wing screws and three Phillips screws have to be removed:

You can leave the screw in the center of the battery housing alone:

Gently you can now pry up/off the casing:

Close up of the cartridge slot we need to remove:

Because I do not want to remove the PCB fully and don’t have any need to try to save the cartridge slot, I decide to cut the pins to the rear of the slot to avoid having to use hot air:

Using solder wick I remove any excess solder from the cartridges ground solder tabs:

Using my solder iron to gently heat up these tabs I can now prise up the cartridge slot and remove it:

Since I cut the pins previously I now need to remove them with my soldering iron:

And with some more use of solder wick I clean up all the contacts:

The original DS cartridge slot (right) versus the new one:

Taking off the top shielding of the original slot we can see how badly mangled the original pins are inside:

The new replacement cartridge slot is now placed into position:

And soldered onto the PCB:

I find that unfortunately I can not close the casing of the DS Lite because of two black pieces of plastic sticking out of the back of the replacement cartridge slot:

So I trim these off:

After re-assembling:

Both are now fully working again.


Super detailed and informative post as usual. I haven’t worked on one of these yet. Super interesting.

1 Like

I really don’t recommend it to be honest.

The third party cases tend to not be moulded very well and end up breaking the charging circuit when you close them together unless you knew in advance to file back the excess plastic inside to give good clearance over certain components.

I learned the hard way sadly… >_<

Replaced plenty of screens and touch screen digitizers in these DS lites over the past couple of years.

Found a fair few with broken charging circuits, bad internal fuses, one with a unfixable bad VDP, many with bad DS and GBA cartridge slots along with the very typical broken hinge issue.

But really as I said already they rarely feel worth the time/effort to repair and can be fiddly to deal with.

1 Like

The pins in the original cartridge slot!!! Wow.

Great post.

1 Like

You dealt with those tabs the right way. I ended up lifting a pad when I replaced the cart slot on a DSL I bought. Live and learn I suppose!

1 Like

I haven’t done one of these in quite a long time as writing up logs and taking all the required photographs takes up a lot of time and I wanted to power through a lot of my backlog of repairs.

So let’s start us off again with something good…

A bit of back story:

So recently a lot of CPS1 arcade PCB have ended up being sold cheaply on AliExpress and while I was hearing a few horror stories, some people were getting good working boards so I decided to take the risk with a seller “Self Love” to make a test single purchase of a cheap CPS1 Motherboard to see how it would turn out as I would like to have more complete CPS1 stacks instead of having to rely on just my single working CPS1 Dash Motherboard.

So it arrives and it is an all original CPS1 Dash board! A Good start!

I then try to boot games with it and well nothing boots, I cycle through a bunch of B+C boards while testing and my Three Wonders boots up to a SCR 1 RAM NG error:

I check around the board and find many bodged trace repairs:

Corrosion on several pins of a LS253:

and suspect ram that looks like it has over heated on the right hand side:

I really was not happy with the state of this CPS1 motherboard and it simply does not work so I reached out to the seller who then made every nonsensical claim trying to get out of that they sent a broken PCB.

Click for an abridged support thread with them if you care to dive into that.

In the end they stopped talking to me and I decided to claim a dispute with them directly with AliExpress.

The sellers only response was:

Buyer should close dispute and file claim with courier. We test all our products before sending.

I rejected that and after a few days AliExpress thankfully sided with me and issued me a full refund with no need to return it.

So now I can see if I can repair it.

But after eliminating the obvious visual damage I had already noted, I started looking at the potentially bad SCR Ram and pulled several of them out of circuit:

After looking up schematics for the RAM I learn they can be tested as 62256 but all three fail:

At this point this is not getting me anywhere and who knows what other issues I might run into on this trash condition CPS1 motherboard so I abandon attempts to repair it.

Not the greatest end to my first new repair log in a long time right?

Oh well…


Okay, clearly that was not the end.

Remember quite a while back I had a CPS1 motherboard that was also faulty and my prognosis was that it was not repairable due to a bad CAPCOM A01 custom PPU?

Check out this earlier Three Wonders CPS1 repair log to catch up perhaps?

Well clearly this Aliexpress Junk CPS1 Motherboard can display the screen correctly for at least the error screen:

So the thought was maybe I can transplant the CAPCOM A01 over to my Three Wonders CPS1 Motherboard that I figured has a bad PPU:


CPS1 CAPCOM A01 Custom PPU Transplant Repair:

So here is the trash AliExpress CPS1 Dash (12mhz CPU + XTAL) and the PPU I want:

A Lot of flux and patience with my hot air workstation later:

A very clean no bent pins pull of the CAPCOM A01 PPU:

So now onto my original Three Wonders regular 10mhz CPS1 motherboard:

A very careful Yoink and clean later:

We now have two pulled A01 PPU (Bad one on the left and marked with a B obviously):

Time to tack down the donor PPU from the junk Aliexpress CPS1 Dash into it’s new home:

Now it is in position I drag solder it onto the regular 10mhz CPS1 motherboard:

and @!#? @!#?ity @!#?ing @!#? it doesn’t boot…

Always a worry you can damage an IC from too much heat when removing them and well I wasn’t 100% sure whether the PPU on the AliExpress junker was any good either…

A quick solder re-flow later:

Quite happy my earlier prognosis turned out to be true and the transplanted PPU turned out to be good, otherwise all of this effort would have been for nothing…

Did I mention I really HATE QFP SMD rework?


Nintendo Wii Optical Drive Not accepting Discs Repair:

A while back I was handed a Nintendo Wii that would not accept optical discs being inserted into it and that would occasionally boot up with this error:

So I opened up the Wii to see if I could find out what was going on.
After removing the optical drive can you spot the problem?

A closer look:

Looks like some child had decided to use the Wii as a money box!

After removing the top of the drive I found and removed £1.55 in change and a sequin:

Then everything was re-assembled and the drive now works fine:


Very cool! I somehow missed this update! I got one of these a little while back. It works but the audio circuit is a crappy rework. I wonder if it’s possible to return it to its original state. At least you know what you had. I thought I’d gotten a legit board. (They sent me one different than in the photo.)

1 Like

Microsoft Xbox 360 Optical Drive repairs:

I got given bunch of faulty XBOX 360 consoles earlier in the year which had been stored in my shed outside for a good while now.

Most had RROD (Red ring of Death) issues and were very early models that were not worth working on, however there was two Jasper revision consoles that booted fine but had none working drives.

The main one I wanted to work on was a Black Jasper:

Opening 360 consoles is a pain in the backside and I recommend you watch a video showing you how to do it prior to attempting it yourself. I am not going to cover the process here so we are skipping ahead:

The drive can now be removed and turn it upside down to see the 4 screws you need to remove:

Once removed you can open pull the metal case apart into two pieces:


This drive was not salvageable due to various reasons, so I wanted to swap in another optical drive from one of the RROD consoles.

HOWEVER, you can not just swap over an optical drive as Microsoft used a hardware key stored on the epoxied (to prevent tampering) IC on the optical drives logic board that MUST match your motherboard.

So to use another optical drive we need to swap this logic board over:

Carefully using tweezers I unclip the three ribbon cables:

Then de-solder the 6 coloured wires. I mark one of the yellow and white wires with a black marker so I know which contacted to what pad for ease:

After removing two small screws the logic board can be removed from it’s original bad optical drive:

This is then swapped onto the donor drive (there are several models so make sure they match):

Once it is soldered back in and the three ribbon cables are connected we can test the drive:

and we have one working 360 Jasper System!

The second working Jasper console had an disc tray that would not open and struggled to play optical discs.

To fix the disc tray not opening issues we need to change the drive belt.

After opening up the optical drive you can push with a small solid implement this small plastic rail inwards (as pictured below) to easily open the disc tray:

This will give us easy access to the belt:

You can see the comparison of the old (left) and replacement (right) belt below:

Now this drive just needed a laser potentiometer adjustment.

The left one is for DVD and the right one is for CD media:

These are adjusted counter clockwise in very small increments to decrease resistance.
You should take a ohm measurement over the potentiometer before adjusting anything (it should be around 5ohm) and do not go below 3ohm or you risk destroying the laser.

After a very tiny adjustment optical media started to work again:

So after working through 5 junk 360 consoles I managed to piece together two fully working ones:


This was one of my concerns as well. There are a lot of CPS1 motherboards that have had the audio circuit fail and Chinese resellers always seem to bodge an audio fix for as cheap and as least effort as possible. Resulting in lots of these “mangled” PCB’s being out there.

It is quite possible to revert it back to original, you just need access to the parts.

Yes they are a huge pain to open… should be illegal!

1 Like

Saisho Portable Cassette Player Repair:

I got given this Saisho BBFX12 portable cassette player to look at as it was not doing anything, the cassette door is loose and there is a rattle of something loose inside:

The owner had tried to get it running with 2xAA size Rechargeable batteries which was the first mistake as rechargeable AA batteries operate at 1.2v whereas regular AA batteries run at 1.5v and this needs the whole 3v to work.

With new regular 1.5V AA batteries inserted I can hear some grinding but nothing is actually happening… So of course we open it up:

Peeking under the PCB I can see the drive belt has dropped off:

and the rattling is caused by a loose spring that I am assuming is for the front door:

This blue wire that is attached to the positive battery terminal is stopping us looking inside:

So we de-solder it and flip the PCB out of the way to the side or at least that is what I should have done had I noticed this was possible until after I had de-soldered the wires to remove it, but hey hindsight eh?

Unfortunately the belt fell totally while doing this so I didn’t quite know how it should sit…

After some trial and error figured out the correct way to put the belt back on:

So much easier to work on when all the wires were re-soldered back in place and only the one blue wire is de-soldered to allow the PCB to be flipped to the side:

Anyway… now that is sorted I needed to figure out how to put the spring back in place.
I notice their is a hole in the door cover and try to put the spring into it:

Then find a small pin hole in the case where I guess it should attach to:

Which means I need to flip the spring around and yes that is it:

The cassette door now springs closed and open correctly again!

I now re-assemble it and let’s try the demo tape I got given:


When I contacted the owner he could no believe that I had managed to get it working again and thought it would just end up being thrown away. So much so that he decided to just let me keep it for my effort made in repairing it!

And with that I have FINALLY made it to 50 repair logs!

This one was a bit off topic for the boards but I have a bunch of other logs to put up all retro game related in the near future.


Love it! Auto reverse AND a radio was the ultimate in luxury back in the day. Absolutely baller as hell to roll around with one of these on your belt :sunglasses:


So cool! Congrats on another great repair.