Issue with Sega CD and Popful Mail [FIXED]

Paging all Sega pros! Ran into an issue with a Sega CD and Popful Mail. Wondering if any of you might know what’s up.

@balb was kind enough to send me his Sega CD so that I could test my copy of Popful Mail. I connected my Model 1 Sega Genesis to the Model 2 Sega CD. Upon booting up I eventually get to the title screen. Sweet!

Once I hit start though…

I did some googling and this error code seems to crop up when using an emulator or attempting to play a pirated copy on legit hardware.

I messaged @balb and he was kind enough to come over with his copy so we could compare. Everything seemed to check out between the two, and both copies played fine on his CDX.

I tried two different Sega consoles as well just to be safe.

What say you RGB? Any thoughts? I don’t have any other Sega CD game to test. Possibly just an issue with the Sega CD unit? Figured someone out there may have run into this before.

Thanks!

Yeah, just to be clear, neither of our copies worked on the Sega CD 2, and they produced that same error message pictured above. They both worked perfectly on the CDX.

This can happen if the internal memory is corrupted. Try formatting it.

2 Likes

Copy protection? Clean the edge connector.

I’m pretty sure that’s a main CPU error :wink:

I haven’t had one in years but yeah format the internal memory and try again, Mega CDs have all sorts of issues with the memory. Some games tell you to do this.

But how can you be sure!? :grin:

Thanks all! I’ll give these things a shot and report back.

Yup this did the trick!

Thanks everyone!

2 Likes

Excellent! This thread is the exact reason I hope forums don’t go extinct. Someone can Google this issue and stumble upon this thread and then they can enjoy some delicious Mega CD!

4 Likes

imo he should now edit his post to just say “never mind, I found the solution” without providing any details. :3

1 Like

We will never go extinct. At worst, we’ll become “retro”

1 Like

Hooray, my Sega CD isn’t buste—I mean…hooray, New002 gets to play Popful Mail finally :slight_smile:

I’m having this same error message pop up. When I reformat the system I can play the game but once I turn off the system I get the error message and have to reformat again. Does anyone know of a way to fix this permanently so I don’t keep losing my saves.

My guess would be that it’s somehow becoming corrupted every time, but maybe someone more knowledgeable can chime in.

I know I’m replying to an old post, but…

The reason the internal save game RAM in your Sega CD is becoming corrupted whenever you turn the system off is likely because the internal battery isn’t charged.

Leave your Sega CD on for a period of several hours, overnight even. Provided the unit’s internal rechargeable battery is still okay, leaving it on will charge up the battery, allowing it to sustain the save game RAM when the system is off.

“This can happen if the internal memory is corrupted.”

Correct.

“Popful Mail” keeps track of how long you’ve played since starting the game and constantly saves this data to the save game RAM. If the formatting of the save game RAM is corrupt, then the game can’t properly function.

Good to know. That makes sense considering the system had probably sat unused for who knows how long. Thanks for the additional info!

You’re welcome. Hope it helps.

Hey.
Thanks for the advice. I gave it a try and the problem is still happening. I think my battery is fried. :frowning_face:

Do you have a multi meter ? It’s very easy to check a battery

I don’t. Is it possible to change out the battery?