PSA: Ray'Z Arcade Chronology Difficulty Settings Fix (set Rapid-fire shots from the PCB to ON... it's OFF by default)

So when it came out, I posted that there was something off about the difficulty settings of RayForce in the Ray’Z collection.

No matter how high I set the difficulty setting, bosses went down too easily compared to the Saturn version, which, as far as I know, is arcade perfect. In fact, you wouldn’t even see some of the phases of the bosses start because you would defeat those phases almost instantly as they were winding up.

And this was a bummer for me since RayForce is literally THE game that got me into Shmups. It’s one of my absolute favorite games of all time, and part of that is due to the perfectly balanced difficulty and incredible boss music.

It turns out, this was due to an option that is not explained that well in the settings menu of the Ray’Z collection. And it’s on the wrong setting by default.

If you go into Game Settings, there is an option called “Rapid-fire shots from PCB.”

You need to turn this “ON.” When it’s set to “OFF,” the rapid fire settings in the game are much higher than the original PCB. Changing this setting to “ON” doesn’t stop the rapid fire from working, but it sets it back down to the rate that was on the original arcade and Saturn releases.

After this, the game, of course, kicked my butt again. But I wouldn’t have it any other way.

I just wanted to put this here as a PSA to anyone out there who noticed the same issue and didn’t know how to rectify it. I would have never expected the default rapid fire setting to essentially break the game as it does.


Nice, I definitely noticed a drop in difficulty on the collection version of RayForce, thanks for posting this.

1 Like

Just got done playing RayForce with the aforementioned option adjusted, noticed the difference right away as soon as I got to the first boss, was definitely harder.

1 Like