8Bitdo Retro Receiver and 8Bitdo SF30 will not pair, any suggestions?


#1

I finally picked up a retro receiver for my SNES to use with the SF30 I bought a while back. I put both of them on the latest firmware and following the directions on 8Bitdo’s website, but nothing I do will get these damn things to pair together. Anyone have any suggestions? I really wish they made an RF version of the SNES controller. My M30 just worked, effortlessly. I’ve now probably spent more time trying to get this damn thing to pair then I have spent using the SF30 since I bought it.


#2

Isn’t the SF30 is a 2.4ghz controller?, my understanding is the retro receiver is only compatible with the older Bluetooth models or 8bitdo DIY kits.

I’ve got a couple of Snes classic mini controllers with DIY boards installed and they work great with my SFC.


#3

No the SF30 is bluetooth, I’ve had it connected to my Switch and PC bluetooth dongle.


#4

Did you buy the retro receiver from 8BitDo or ebay/amazon?


#5

I bought it off Amazon, so I just requested a replacement, since it will not sync with anything I try to sync it with.


#6

Some of the 8bitdo stuff on Amazon are copies, unless they are sold by 8Bitdo themselves


#7

Citation needed. :balance_scale:

When/where were copy 8bitdo devices confirmed? How can you spot a copy? How prevalent are they? Are they absolutely proven to be less likely to work?


#8

How are you switching on the SF30? Using which button combo? And how are you attempting to sync to the RR?


#9

#10

What are they?


#11

It was sold by 8bitdo on Amazon, so I don’t think its a fake.

I was following 8bitdo’s procedure. Press start for a second to turn it on, and then hold down select for 3 seconds to put the controller in pairing mode. Turn on the console (or plug the receiver into a PC) and hold down it’s sync button, and when they stop flashing they should be synced. Never happens, I’ve followed 8bitdo’s instructions for putting the controller into sync mode for its various modes, including the xinput and switch ones. I’ve tried with DS4’s and the SF30 Pro. Thing just doesn’t want to sync. A replacement will be here tomorrow.


#12

My sfc30 wont pair with the adapter unless I turn it on and repeatedly press a button. If I don’t press anything it times out. While the light is blinking I just sit there tapping up on the dpad until I see it start moving.


#13

Yeah mine is also awkward but I don’t have it here with me to remember how I synced it.


#14

Pairing was such a pain in the ass with the bluetooth SF30 and the NES and SNES retro receivers that I went with the 2.4G version of the Mega Drive controller. No regrets, can’t be bothered dealing with pairing issues when I only have an hour to play.


#15

I did the same thing for ages when I got the DIY ones, then realised I wasn’t on the actual latest firmware.

Worth a double check, SF30 was discontinued quite a while ago (two years?). The page was slightly confusing when I was doing it and I had the second most recent firmware.


#16

It was definitely the right firmware, got the replacement today. Updated it and it synced in about 2 seconds. So just something up with that first one.


#17

Glad it’s sorted for you, nothing more annoying than stuff that doesn’t work properly.