Sega Dreamcast |OT| It's Still Thinking


#161

Looks like he got an updated pcb:


#162

Excited to get a VMU tonight to finally be able to save games! Yeah! …oh wait, no. :frowning:

VMU was advertised as new, looks new and unopened (likely new old stock). Purchased here on ebay. Opened it, pulled the battery tab, hit the reset button, able to set date, times, etc. I plug it into the controller and…nothing. Controller doesn’t work until I pull out the VMU. VMU needs to be reset to work again. I replaced the batteries in the VMU with brand new batteries and still same thing. Tried both VMU slots, tried wiggling it around.

This is a used DC, don’t know pedigree, and also came with a 3rd party controller, which some search results say is a likely culprit of frying a resistor. Tried the 3rd party controller and it has the same results for both VMU slots: controller is unresponsive until I remove the VMU. Tried OEM controller on controller ports 1 & 2, same thing, nada. Decided not to proceed testing for ports 3 & 4.

I’ve barely used the DC and when I do it’s usually been off power for a while. However, while testing tonight I noticed that if I turn it off but keep power supplied to it, when I turn it back on after only like 2 minutes it prompts me to set the date/time again (this is the console not the VMU). This indicates to me something is wrong inside the console.

I don’t have time to tear into it tonight, or search around online much more, but interested if anyone has recommendations on where to start looking. I plan to clean the controller VMU contacts, might even do a whole controller teardown/clean. I’ve found some forum posts similar to what I’m experiencing here and here. I will likely also open up the console and take a look around. Unfortunately I don’t have any other OEM controllers to test. I may stop by some local game shops to see if they have any after cleaning mine, assuming that doesn’t fix it.


#163

It’s possible that the NOS VMU was in a moist area and has some corrosion on the contacts? Given that the first link you found of someone with the same problem involved cleaning the VMU, that’s the only thing I can think of that would affect something still in the box, however unlikely that may seem?

I have never had that problem. I have blown the capacitor that acts as a jumper on the controller port board in both systems I own. I read up on that and it’s kinda bad design from what I could find so I used the ghetto fix and just twisted the wires together to take it out of the equation and controllers started working fine again. Different issue, but something that’s flaky with Dreamcast.


#164

Isn’t there a battery inside the console too? I forgot how this works.

I actually don’t keep a battery in my VMU because it only lasts like a month or so anyway. It still works as a memory device even if there is no battery power. And I never keep an accurate date on my DC console because it’s going to get reset eventually anyway.

It’s been 1999 for about 19 years now as far as my DC is concerned.

But it sounds like your VMU is corrupt or something. Definitely try to grab another one. They’re pretty cheap.


#165

Thanks for the suggestions. I plan to clean the contacts on the VMU and controller when I get some time. I fortunately (unfortunately?) bought two VMU’s so I’ll try the other one too. I see no indications of it being counterfeit, but I’m also way lttp on Dreamcast. I’ll also take a look inside the console like I stated above. Everything else seems to work fine with it.


#166

VMU can causes a lot of issues. Whenever my VMU is on, the DC don’t boot Zombie Revenge no matter what. If I unplug the VMU, the Game boots normally.


#167

I can’t imagine anyone would take the time to make a fake VMU considering how little they’re worth.


#168

Me neither but who knows lol. Hopefully I’ll have some time to try to get it working later tonight.

FYI, there is a battery for the clock inside the console. It’s rechargeable, according to what I’ve read, but only charges when the system in powered on.


#169

I keep meaning to pick up a Mad Catz Dream Pad having read some people use them in preference to the official controller. Anybody here do that?


#170

No DreamCast Classic: You Motherfuckers Had Your Chance to Buy One the First Time


#171

Ah now that makes me think my Sega Saturn S-video cable might be fake then. I’ll have to take a look. The only way to check is likely open it up right?


#172

Open up my DC, the F1 fuse resistor on the controller port is blown which is likely, I’m hoping, why the VMU doesn’t work. No continuity and no resistance across it. I’ll use this guide as a baseline to try to replace it:
https://www.ifixit.com/Guide/Sega+Dreamcast+Controller+Port+Replacement/1562

@BarrelCannon I’m not sure, I haven’t opened up cables before. Presumably there is a less intrusive way to test it but perhaps others can chime in on that.


#173

I think that’s the one that blew on me. Don’t replace it. You’ll just blow it again. Either remove it or complete the circuit by twisting the wires together. You will never have problems again.


#174

Heh, reminds me of an article in the style of The Onion.


#175

Maybe try not to overthink things and try a different VMU…would be wise advice that I didn’t listen to until tonight.

Tried the other one I bought, I really second guessed why I would buy two, but this one works and the other one didn’t.

/Duffman oh yeah!

Yes, I named my Record of Lodoss War protagonist Alucard, lol.

Edit, I did twist the resistor but that had no impact on the first VMU not working and the second working.


#176

Cool. I honestly have never heard of a VMU acting that way. Wacky. That resistor is a pita though.


#177

This is hysterical and probably true.